首先 经过我测试,php74模块没有支持apache的.所以升级到php74 之后,php无法使用. 最基本的函数phpinfo 调用不出来,没有相关的模块.
安装mariadb 10.4 之后发现,mariadb 这个版本好像不支持密码(反正我是没搞定,一天) .改配置什么的我都试了,仍然免密登陆. 所以最后经过我测试了一天 确定的方案就是 php72+mysql8.0 (依旧遇到了相当多的问题, 包括mysql和mariadb版本冲突,配置冲突,以及和php的模块冲突,为了不浪费时间去改配置,系统我重装了五次左右.血与泪的实践)
下面开始正确的步骤,首先安装mysql 仓库,从官方下载仓库文件,传到服务器 或者拿到链接,采用wget的方式

wget https://dev.mysql.com/get/mysql80-community-release-el7-3.noarch.rpm 下载后通过本地安装
yum localinstall 包

SRE实战 互联网时代守护先锋,助力企业售后服务体系运筹帷幄!一键直达领取阿里云限量特价优惠。

刷新仓库 yum clean all

重建缓存 yum makecache

安装mysql yum install mysql (一定要先安装mysql再安装php 否则到时候模块找不到支持,先安装了MySQL之后,模块方便自动识别版本.否则到时候版本错误,有得回退半天,然后清理配置,出现莫名其妙的错误)

安装好之后,进入mysql 这时候需要密码.但是你没有设置密码,哪来的密码呢? 这是MySQL 高版本的特性,它会生成一个随机密码
在你 mysql-uroot -p 之后 要求输出密码, 确定之后提示没有密码,然后, 查看MySQL 日志 cat var/log/mysqld.log |grep password 就可以看到这个生成的随机密码(找不到多的登陆几次)刷新下

然后 mysql-uroot -p 拿到的随机密码.登陆进去,必须立刻重置密码

alter user 'root'@'localhost'IDENTIFIED BY 'YourNewPass'; -->mysql8.0的密码规则比较严,要求账号包含大小写,数字符号 长度为8, 两次确认密码之后 后面几个选项全部默认Yes

重置完密码,新建一个wordpress 数据库

create database wordpress ; \q 退出.

安装php --> 因为官方没有高版本的源. 只有5.4好像,wordpress 最低要5.6 还是更高来着,反正阿里云仓库没有,其他的都没有.

安装php72w,是需要配置额外的yum源地址的,否则会报错不能找到相关软件包。

php高版本的yum源地址,有两部分,其中一部分是epel-release,另外一部分来自webtatic。如果跳过epel-release的话,安装webtatic的时候,会有错误爆出。

所以,这里需要的命令是:

rpm -Uvh https://dl.Fedoraproject.org/pub/epel/7/x86_64/Packages/e/epel-release-7-11.noarch.rpm

rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

当然,您也可以选择下面的这个命令,也是一样的效果。

yum install epel-release -y

rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

记得更新源之后重建缓存
yum clean all
yum makecache

如果之前有装过php 为了防止CentOS上面发生php冲突,所以,这个命令还是先执行一下更好些。
清除历史版本
yum -y remove php*
安装扩展包

事实上,这里面的对应扩展库很多,这里大家一定要注意cli和fpm这两个包,而其它的相关包就看需要了。

yum -y install php72w php72w-cli php72w-fpm php72w-common php72w-devel

最好装这个
yum -y install php72w php72w-cli php72w-fpm php72w-common php72w-devel php72w-embedded php72w-gd php72w-mbstring php72w-mysqlnd php72w-opcache php72w-pdo php72w-xml

安装完成以后,启动服务
systemctl enable php-fpm.service 设置开机启动

systemctl start php-fpm.service 启动php-fpm

然后开始安装apache

yum install httpd
systemctl enable httpd
systemctl start httpd
这时候访问 能访问到标准apache 测试页面
然后进入到网站目录 /var/www/html
新建一个php 文件 用来测试
vim index.php 添加测试代码
<?php
phpinfo();
?>

保存退出之后,访问地址,如果出现php版本信息页面说明php链接成功.
可以开始下一步.
下载wordpress ,wge 下载之后解压.
新建一个 网站根目录 webroot/wordpress
将解压的wordpress 全部移动到这个文件夹

再来配置虚拟主机
vim /etc/httpd/conf.d/vhosts.conf
添加代码
<VirtualHost *:80>
ServerName 网站地址
ServerAlias 别名网站地址
DocumentRoot "/webroot/blog" //刚刚新建的文件夹

<Directory "/webroot/blog">
Require all granted

保存退出,然后重启httpd

访问服务器地址, 最好在配置虚拟主机之后,再通过之前我说的方法, 写一个php测试页,看虚拟主机能不能访问php成功,成功了就可以放心开始下一步了.

进入到相关页面.配置页面.提示数据库链接,名称,账户,密码 ,分别输入我们刚刚设置的数据库信息,这时候问题就来了,发现无论如何无法写入,提示数据库有问题. (确定账户密码什么的没问题.)
wordpress 配置坑详解 Linux 第1张

其实这是为因为我采用的是高版本的mysql8.0 ,之前修改密码之后默认安全策略是不让外部访问的. 以及 服务器要求的身份验证方法对客户端未知。提示服务端(要连接的数据库)所要求的验证方式为caching_sha2_password。
打开phpinfo(),查看当前安装的php版本中的配置信息,找到mysqlnd.

当前PHP版本中所带的mysqlnd无法支持这种验证(caching_sha2_password),而PHP默认的是mysql_native_password 。
MySQL中以root登录,并查看数据库所默认的身份验证
select host,user,plugin from mysql.user where user ='root';
wordpress 配置坑详解 Linux 第2张

解决方法 :
MySQL中创建一个支持mysql_native_password验证的用户,并用该用户登录管理wp_database数据库。

创建一个认证方式是mysql_native_password的用户

create user '你的账户'@'localhost' identified with mysql_native_password by '你的密码';

创建要存放wordpress数据的数据库,指定字符集

create database wp_database default charset utf8 collate utf8_general_ci;

将wp_database的所有权限给用户 你的账户

grant all on 创建的wordpress数据库名称.* to '刚刚创建的账户'@'localhost';

然后再刷新网址 就可以登陆成功了.

如果还是不行,

修改配置
1,登进MySQL之后,

2,输入以下语句,进入mysql库:

use mysql

3,更新域属性,'%'表示允许外部访问:

update user set host='%' where user ='root';

4,执行以上语句之后再执行:

FLUSH PRIVILEGES;

5,再执行授权语句:

GRANT ALL PRIVILEGES ON . TO 'root'@'%'WITH GRANT OPTION;

然后外部就可以通过账户密码访问了。

)

扫码关注我们
微信号:SRE实战
拒绝背锅 运筹帷幄