Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 33682   Accepted: 12194

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

SRE实战 互联网时代守护先锋,助力企业售后服务体系运筹帷幄!一键直达领取阿里云限量特价优惠。 The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>

using namespace std;
const int N=1e3+10;
int s[N][N];
int n;
int lowbit(int x)
{
    return x&(-x);
}
void updata(int x,int y,int z)
{
    for(int i=x;i<=n;i+=lowbit(i)){
        for(int j=y;j<=n;j+=lowbit(j)){
            s[i][j]+=z;
        }
    }
}

int sum(int x,int y)
{
    int res=0;
    for(int i=x;i>0;i-=lowbit(i)){
        for(int j=y;j>0;j-=lowbit(j)){
            res+=s[i][j];
        }
    }
    return res;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        memset(s,0,sizeof(s));
        int m;
        scanf("%d %d",&n,&m);
        while(m--){
            char t[3];
            scanf("%s",t);
            if(t[0]=='C'){
                int x1,y1,x2,y2;
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                updata(x1,y1,1);
                updata(x2+1,y2+1,1);
                updata(x2+1,y1,-1);
                updata(x1,y2+1,-1);
            }
            else{
                int x,y;
                scanf("%d %d",&x,&y);
                printf("%d\n",sum(x,y)%2);
            }
        }
        if(T) printf("\n");
    }

    return 0;
}

 

扫码关注我们
微信号:SRE实战
拒绝背锅 运筹帷幄